User Tools

Site Tools


nvidia-smi-debian

Getting nvml_fix to work adequately on Debian

nvml_fix is an excelent piece of hackery. It gets your nvidia-smi showing some stats usually only “supported” on flagship GPU's. Go check out the link for more information.

There's a small perk, though. README mentions dpkg-divert etc. but it won't solve the problem. Install nvidia-smi package as normal, then rename the symbolic link libnvidia-ml.so.1 to libnvidia-ml.so.VERSION (like …so.666.66). Then do the make install accordingly. The reason is: libnvidia-ml.so.1 is nvml_fix hacking itself into the middle, but it still needs to find the original Nvidia library. If you run ldd libnvidia-ml.so.1, you can see where it expects to find the original library.

And voilà

Source: idk, I just ran into that mess a bit too many times.

nvidia-smi-debian.txt · Last modified: 2020/09/09 04:21 by prppedro